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GETTING STARTED 

After installing the extensions, follow the instructions below to set up the actions. 

INSTA L L ING THE A CTIONS 

If you already have your actions set up, you can skip this process. 

1. Open Adobe Illustrator and go to Window > Actions 

 
2. From the Actions panel go to the menu in the upper right and select Load Actions… 

 
3. Load the alc_actions.aia file. 

 

 



START FLOOR PLAN 

With Adobe Illustrator open, go to Window > Extensions > Start Floor Plan 
 

 

 

 

 

 

The Start Floor Plan extension has 3 options: 

1. New File From Template 
2. Open AI File Exported From Fireworks 
3. Open SVG 

 

 

 

 

 

NEW FIL E FROM TEMPL ATE 

This option opens a new file from a pre-made template. The default template is in the extension itself, but you can 
also use a template file you’ve created. 

1. Go to Window > Extensions > Start Floor Plan

 



2. Make sure the Template File in the Start Floor Plan panel is set to /resources/floor-plan/MainTemplate.ait 

 
3. Click New File From Template 
4. You should get a black artboard with your layers set up

 



5. Select the Scan layer and go to File > Place… or press SHIFT + CTRL + P 

 
6. Load the background image you’ll be tracing. If it comes from a Fireworks file, hit OK on the warning 

popup. 

 
7. Readjust the reference image and lock your Scan layer. 
8. Start drawing your walls on the appropriate layers. 

 

 



OPEN A I FIL E EXPORTED FROM FIREWORKS 

This option allows you to open AI files that were exported in Fireworks. Use this process instead of opening the file 
directly. Otherwise, you may run into errors. 

1. Open your legacy floorplan .png file in Adobe Fireworks 
2. Make sure the layers are intact 
3. Go to File >  Save As… and choose Illustrator 8 (.ai) as the Save as type. 

 
4. Back in Adobe Illustrator, go to Window > Extensions > Start Floor Plan 

 



5. Click on Open AI File Exported From Fireworks and select the ai file you just saved from Fireworks. 

 
6. Start associating your zones or making edits. 

OPEN SVG 

When making edits to existing .svg files, use Open SVG from the Start Floor Plan extension. If you open the .svg file 
directly, Illustrator will group everything and change the layer names. 

1. If you already have the .svg file and don’t need to export it from Viewbuilder, skip to step 5. 
2. Open your .view file in Viewbuilder. 
3. Select the floorplan and go to the Control Properties panel. 

 
4. Click on the Export Image button on the General tab to export the .svg file. 
5. In Adobe Illustrator, go to Window > Extensions > Start Floor Plan

 



6. Click on Open SVG and select the svg file you want to edit. 

 
7. You will now be able to make edits to your svg floorplan. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



DESIGN EXTENSIONS 

This is where the majority of your extensions exist. Go to Window > Extensions > Design Extensions to bring up the 
Design Extensions panel. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

L INE STYL ES 

These extensions change the styles of the lines in your floorplan. For the Floor Plan Lines and Summary Lines 
extensions, black lines are generated and placed on layers that end in “BLACK” in their names. You don’t need to 
select anything to run these extensions. 

 

 

 

 

 



FL OOR PLAN L INES 

 

SUMMARY LINES 

 

COL OR L INES 

 

 

 



GENERA TE SHA PES 

These extensions are for creating shapes that are used with other extensions.  

DUCTING BACKGROUND 

A semi-transparent black layer created with this extension is used for highlighting the ducting in the browser. You 
do not need to select anything to run this extension. 

3D WALLS FROM WALLS 

This extension copies walls and columns to a 3D Walls layer and edits them to work with the SVG Floorplan built-in. 
After running the extension, you should see solid black rectangles overlaying the walls on your floorplan. 

ZONE SHAPES FROM DIVIDERS 

When making edits to floorplans, you may want to generate additional zones. This extension will just generate the 
zone shapes, allowing you to delete the ones not needed and then using the Zones From Selection extension to 
make these shapes into programmable objects. 

A REA  SHAPES FROM DIVIDERS 

Same as Zone Shapes From Dividers, but with areas. 

FL OOR SHAPES FROM DIVIDERS 

Same as Zone Shapes From Dividers, but with floors. 

GENERA TE PROGRA MMABLE OBJECTS 

These extensions set up a programmable object that can be associated in the Geo Tree extension. Some create the 
programmable object based on divider lines, while others convert existing objects into programmable objects. A 
programmable object is a set of layers with sub-layers. The top layer defaults to being named “ProgOb”. 
Depending on what the ProgOb layer’s parent layer is, there are 1 to 3 of the following sub-layers: Fill, Stroke, or 
Labels. Fill and Stroke hold any programmable shapes that the programmable object has. While Fill is for shapes 
like zones, Stroke is for lines like ducting runs. The Labels sub-layer holds onto any labels for that Programmable 
Object. 

 

 

 

 

 

 

 

 



ZONES FROM DIVIDERS 

This extension generates zone programmable objects from the Exterior Walls, Zone Walls, and Zone Dividers. The 
zones will be that greyish-brown color and have a label that says “Label" on it. You do not need to select anything 
to run this extension. 

 

ZONE FROM SELECTION 

This is another option for creating Programmable Objects on the Zones layer. 

1. Draw your polygon on the Zones layer using the pen tool or any other drawing tool. 
2. Select the polygon. 
3. Run the Zone From Selection extension. 
4. Your polygon should have changed to a greyish-brown color and a text object that says “Label” should 

have been generated. 

ZONES FROM ARTBOARD 

To create zones for just a single artboard, use the Zones From Artboard extension. This works well with the 
Duplicate Artboard extension. Go to Design Extensions > Other > Duplicate Artboard for more instructions on 
setting that up. You do not need to select anything to run this extension. 

 

 

 

 



FL OORS FROM DIVIDERS 

Similar to Zones From Dividers extension, this extension generates a programmable object from the Exterior Walls. 
The programmable objects on the Floors layer are used for navigation in the SVG Floorplan built-in. You do not 
need to select anything to run this extension. 

 

FL OORS FROM A RTBOARDS 

If you have each of your floors on a separate artboard, you can run Floors From Artboards to generate 
programmable objects that fill up each of the artboards. You do not need to select anything to run this extension. 

FL OOR FROM SELECTION 

This is another option for creating Programmable Objects on the Floors layer. It works just like the Zone From 
Selection extension. 

1. Draw your polygon on the Floors layer using the pen tool or any other drawing tool. 
2. Select the polygon. 
3. Run the Floor From Selection extension. 
4. Your polygon should have changed to a semi-transparent black color and a text object that says “Label” 

should have been generated. 

 

 

 

 



A REA S FROM DIVIDERS 

Similar to Zones From Dividers extension, this extension generates a programmable object from the Exterior Walls 
and Area Dividers. The programmable objects on the Areas layer are used for navigation in the SVG Floorplan built-
in. You do not need to select anything to run this extension. 

 

A REA  FROM SELECTION 

This is another option for creating Programmable Objects on the Areas layer. It works just like the Zone From 
Selection extension. 

1. Draw your polygon on the Areas layer using the pen tool or any other drawing tool. 
2. Select the polygon. 
3. Run the Area From Selection extension. 
4. Your polygon should have changed to a semi-transparent black color and a text object that says “Label” 

should have been generated. 

EQUIPMENT FROM LAYERS 

See the Open Elements File instructions before running this extension. This extension takes any of the equipment 
boxes on the Equipment Boxes layer and Summary Equipment layer and makes them Programmable Objects. You 
do not need to select anything to run this extension. 

SENSORS FROM LAYER 

See the Design Extensions > Other > Open Elements File instructions before running this extension. This extension 
takes any of the sensor labels on the Equipment Boxes layer and makes them Programmable Objects. You do not 
need to select anything to run this extension. 



VA VS FROM LAYER 

If you are programming VAV boxes in your floorplan, drawing the equipment on the VAVs layer and run the VAVs 
From Layer extension. You do not need to select anything to run this extension. 

DUCTING FROM SELECTION 

Whether or not you’re programming the ducting in your floorplan, this extension will also generate diffusers and 
place everything on the correct sublayers. 

1. Select the ducting lines that will share the same ref name. 
2. Run the Ducting From Selection extension. 
3. There will be a square representing a diffuser at the end of each line. 
4. Delete any unnecessary diffuser squares. 

3D WALLS FROM SELECTION 

For navigating in the SVG Floorplan built-in, you need to associate your 3D walls to match the floors they’re on. 

1. Select all of the 3D Walls shapes that overlay a single floor. 
2. Run the 3D Walls From Selection extension. 
3. Your 3D walls should have gone invisible. 

FIND A ND REPL A CE 

This allows the user to find and replace the names of layers. Use the Find and Replace text fields along with the 
extensions. For find/replace on text objects instead of layer names, use Illustrator’s built-in option (go to Edit > 
Find and Replace…) 

 

 

 

 

 

FIND/REPLACE IN FILE 

Performs a find and replace on all the layers in the file. You do not need to select anything to run this extension. 

FIND/REPLACE IN SELECTION 

Performs a find and replace on the layers of the selected objects. 

HIDE A ND L OCK L AYERS 

These extensions are to make the whole process a little easier. You do not need to select anything to run these 
extensions.  



HIDE/REVEAL FLOORS A ND AREAS 

Toggle between hidden and visible for the Floors and Areas layers. 

L OCK/UNLOCK BLACK L INES 

Toggle between locked and unlocked for any layers that end in “BLACK” for the layer name. 

L OCK/UNLOCK SCAN AND BACKGROUND 

Toggle between locked and unlocked for the Scan and Background layers. 

OTHER 

Miscellaneous extensions that don’t fit any other category 

EXPORT 

This is the extension that should be run when exporting your SVG files. Do not use the options from the File menu 
or just save your SVG file. 

1. Run the Export extension. 
2. Select the folder to save the file to and make sure the following settings are used: 

 
3. Click Export 
4. Make sure the SVG Options uses the following settings: 

 



5. Click OK 

OPEN ELEMENTS FILE 

For any elements you would normally place into your floorplan without drawing them from scratch, run the Open 
Elements File to open an elements.ai file. This file contains several different elements: 

• Stairs 
• Elevators 
• Doors 
• Windows 
• Equipment 
• Sensors 
• Columns 
• Restroom Symbols 
• VAVs 
• Parking Symbols 
• Sports Fields 
• Water 
• Helicopters 

 

 

 

 

 

 



DUPL ICATE A RTBOARD 

When working on multiple floors with similar walls, you may want to duplicate a floor while maintaining the layer 
structure without duplicating the zones. You do not need to select anything to run this extension. 

1. Make sure the desired floor is on a single artboard. 

 
2. Make sure that artboard is the active artboard. (You may want to rename your artboards to match your 

floor names) 

 
3. Run the Duplicate Artboard extension. 

 
4. See the Design Extensions > Generate Programmable Objects > Zones From Artboard instructions for 

using the Zones From Artboard extension. 

 

 



GEO TREE 

The Geo Tree is used for making associations with your Programmable Objects. It emulates the geographic tree 
inside of the associate window in Viewbuilder. In order to use these extensions, make sure you have the .xml file 
generated by the Graphics Markup Tool and provided by the dealer. 

  

OPEN FIL E 

1. Run the Open File extension in the Geo Tree panel. 
2. Select the .xml file generated by the Graphics Markup Tool provided by the dealer. 
3. Click Open. 
4. Wait for the geo tree to finish loading. 

NA VIGA TING THE GEO TREE 

This is not a button in the Geo Tree panel. These are just instructions on how to navigate the geo tree. 

The arrows to the left of the areas and equipment on the geo tree can be toggled to collapse and expand the 
children underneath. Left clicking collapses or expands the immediate children, while right clicking on the arrows 
expands or collapses all of the children underneath.  

 

 



MA KING A SSOCIA TIONS 

This is not a button in the Geo Tree panel. These are just instructions on how to make associations with the geo 
tree. 

1. Select a shape or label of a programmable object that needs to be associated. 
2. Right click on the name of the area or equipment in the geo tree. 
3. If the programmable object was not associated already, the name of the ProgOb layer will change to the 

ref name, the text objects in the Labels sub-layer will match the name of the area or equipment(unless if 
the programmable object is a sensor), and shapes in the Fill or Stroke sub-layers will change color. 

a. Zones 

  
b. Sensors (no visible change) 
c. Areas and Floors 

  
d. 3D Walls (no visible change) 

4. Once the object is associated, the area or equipment is highlighted in the geo tree 

 
5. If the programmable object was already associated, it changes to whatever equipment or area you’ve 

clicked on. 
6. If the area or equipment that you right click on in the geo tree is already associated to a different 

programmable object than the one selected, and that other programmable object is in the same parent 
layer as the selected programmable object, then a pop-up will ask if you want to continue. 

 



7. Clicking Yes will transfer the association. 

  
8. If the area or equipment is already associated to the selected programmable object, the object will 

become dissociated. 

QUICK A SSOCIATE 

This is not a button in the Geo Tree panel. This extension was set up as an action in Getting Started > Installing the 
Actions of these instructions. 

If you want to go down the line on the geo tree and associate without going back and forth between your artboard 
and the geo tree, you can use the Quick Associate extension. 

1. Left click on the first area or equipment on the geo tree you want to associate. (it will highlight blue) 

 
2. Select the programmable object you want to associate. 
3. Hit F2 on your keyboard. 
4. The geo tree should show that equipment or area associated and moved on to the next area or 

equipment. 

 



5. Repeat steps 2 and 3. 

DISSOCIA TE 

While selecting an associated Programmable Object, you can use the Dissociate extension to dissociate the 
Programmable Object without going through the geo tree. 

   

MERGE 

If you need to combine multiple Programmable Objects into one, use the Merge extension. This is usually when 
there are multiple zones that share the same ref name. 

1. Select each of the Programmable Objects that need to be merged. 
2. Run the Merge extension. 

  
3. The Programmable Objects are combined into one and the labels of the old Programmable Object are 

deleted. 
4. If you need to make new labels, copy and paste the labels from the merged Programmable Object. 

 

 

 



DETA CH 

If merged Programmable Objects need to be split into individual Programmable Objects, use the Detach extension. 

1. Select the shapes that need to be detached from a Programmable Object. 
2. Run the Detach extension. 

  
3. The selected shapes are moved out of the old Programmable Object and a new Programmable Object is 

created from the selected shapes. 

REF NA MES 

Use this extension to toggle the ref names on and off next to the area and equipment names. 

 

REFRESH TREE 

When undoing and redoing in Illustrator, the geo tree won’t update the highlights for the associated areas and 
equipment. To update that, run the Refresh Tree extension. 

 

 

 

 

 



DATA FILE 

This advanced feature allows you to further manipulate your floorplans. Some of these features replicate the 
advanced tab for the association window in Viewbuilder. Other features are unique to SVG Floorplans. This 
extension also imports and exports the data file itself, a JSON file that holds all the information of the data file 
table. This JSON file is used imported into Viewbuilder to apply these settings. 

 

 

 

 

 



REFRESH TA BL E 

If you’ve programmed your file’s programmable objects, you can populate the table for the Data File panel with 
the Refresh Table extension. This will also re-populate your table after making changes. 

 

NA VIGA TING THE DA TA  FIL E TA BLE 

This is not a button in the Data File panel. These are just instructions on how to navigate the data file table. 

The checkboxes at the top allow you to toggle the visibility of the various columns in the data file table. Type and 
Path are always visible, and Hotspot, Variable Color, Hover Text, and Conditional Hover are visible by default. 

Each row in the table is a programmable object that has been programmed, and the checkbox to the left of each 
row is used for the Remove Rows extension. 



Clicking on the row will select the programmable object it represents, and clicking on the programmable object 
then refreshing the tree will highlight the matching row. 

TYPE 

This is the name of the layer that the programmable object is on. 

PA TH 

This is the name of the programmable object layer and the GQL path used by WebCTRL or iVu. Types can not share 
the same path, but you can use the same path for programmable objects that are different types. 

HOTSPOT 

This option will make the programmable object clickable and clicking on the programmable object will bring you to 
the location in the geo tree. 

VA RIA BLE COLOR 

This option will make the programmable object change color based on the path or the conditional expression. 

HOVER TEXT 

This is the text that will be shown when the user hovers over the object with their mouse. 

CONDITIONAL HOVER 

If there is a conditional expression in the Conditional Hover text box, the hover text changes to the value output of 
the conditional expression. 

CONDITIONAL EXPRESSION 

If there is a conditional expression for this programmable object, and variable color is checked, the color will 
change based on the conditional expression instead of the GQL path. 

CONDITIONAL LABEL 

If there is a conditional expression in the Conditional Label text box, the labels in the Labels sub-layer of the 
programmable object will change text based on the output value. 

A CTION BUTTON, CATEGORY, INSTANCE, TAB 

If you want to navigate to specific locations in WebCTRL or iVu, you can use the whereami manual command to 
find the Action Button, Category, Instance, and Tab values of that location in your system. Copy and paste these 
values to these 4 columns so that clicking on the programmable object brings you there. 

OPEN FIL E/SA VE FIL E 

These allow you to import and export JSON files that contain all the information in the data file table. 

 

 



REMOVE ROWS 

With the checkbox to the left of the row checked on, use the Remove Rows extension to remove that row. If you 
want to remove all the rows, first click the checkbox to the left of Type. 

  

UNDO/REDO 

Undo or redo the last action within this panel. 


	Getting Started
	Installing the Actions

	Start Floor Plan
	New File From Template
	Open AI File Exported From Fireworks
	Open SVG

	Design Extensions
	Line Styles
	Floor Plan Lines
	Summary Lines
	Color Lines

	Generate Shapes
	Ducting Background
	3D Walls from Walls
	Zone Shapes From Dividers
	Area Shapes From Dividers
	Floor Shapes From Dividers

	Generate Programmable Objects
	Zones From Dividers
	Zone From Selection
	Zones From Artboard
	Floors From Dividers
	Floors From Artboards
	Floor From Selection
	Areas From Dividers
	Area From Selection
	Equipment From LayerS
	Sensors From Layer
	VAVs From Layer
	Ducting From Selection
	3D Walls From Selection

	Find And Replace
	Find/Replace in File
	Find/Replace in Selection

	Hide and Lock Layers
	Hide/Reveal Floors and Areas
	Lock/Unlock Black Lines
	Lock/Unlock Scan and Background

	Other
	Export
	Open Elements File
	Duplicate Artboard


	Geo Tree
	Open File
	Navigating the Geo Tree
	Making Associations
	Quick Associate
	Dissociate
	Merge
	Detach
	Ref Names
	Refresh Tree

	Data File
	Refresh Table
	Navigating the Data File Table
	Type
	Path
	Hotspot
	Variable Color
	Hover Text
	Conditional Hover
	Conditional Expression
	Conditional Label
	Action Button, Category, Instance, Tab

	Open File/Save File
	Remove Rows
	Undo/Redo


